索恒科讯

热点

如何用kdj背离条件选股公式

时间:2021-08-01 02:05

  老师,请编写一个用于通达信的KDJ J值抬头和股价下跌背离的选股公式。

   J交叉:=CROSS(KDJ.J,KDJ.K) AND CROSS(KDJ.K,KDJ.D);
{底背红买}
K值:=KDJ.K;
DD:=C=LLV(C,60);
DDSJ:=BARSLAST(REF(DD,1));{上一低点时间}
DDGJ:=REF(CLOSE,DDSJ+1)>CLOSE;
KDZB:=REF(K值,DDSJ+1)<K值;
K底背离:=DDGJ AND KDZB;
XG:J交叉 OR K底背离;

如果要二个条件同时成立,则用:
XG:J交叉 AND K底背离;

经测试,信号很小。 KDJ背离选股公式

   现货白银才有用 这个指标不能用它不靠 大智慧KDJ顶背离选股公式

   J:=KDJ.J;
B1:=REF(J,1)=HHV(J,7) ;
A2:=BARSLAST(REF(B1,1));
A3:C>REF(C,A2) AND B1 and J<REF(J,A2) ;
这个指标会滞后一根K线显示,因为当前是很难判断j 值是不是成了一个峰,所以就再加了一个条件就是其后一个周期的是J值会小于前一周期的J值,如此就形成了一个峰。
补充:因为如果那个最后一个周期的J值小于0,基本上很少有满足条件的。所以我也就没写进去。如果按照你的意思,当前的(最后一周期)的J 值小于0,是为第二峰的J值在最高点处且J<0,源码如下:
J:=KDJ.J;
B1:=REF(J,1)=HHV(J,7) ;
A2:=BARSLAST(REF(B1,1));
A3:C>REF(C,A2) AND B1 and J<REF(J,A2) and ref(j,1)<0; 求KDJ顶背离选股公式

   有用么?KDJ,MACD,MA,BOLL我都曾用心去研究过,也用此方法操作过,作用都不大,指标对历史来说看起来都很有作用,但对后市来说都很迟缓,可能是我还没去找到真正的方法吧. 所以什么指标都不看了,只看量价和大盘 求助KDJ选股公式

   公式如下:
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
xg:count(J<0,3)>0 AND CROSS(J,K);
如果符合楼主的意思,别忘了设置为最佳答案。 KDJ走势选股公式

   KDJ指标的参考价值在于横盘整理期间比较有效,在趋势行情中错误信号比较多,因此,这就要看横盘整理是发生的什么情况下应用,如果是在顶部横盘,就不可以作为买入股票的时机,道理很简单,除非你是买在最低价位,否则你任何价位的买入都是错误的,即使是做短线制度都是高风险。反之,如果是发生在底部横盘,则可以考虑短线买入机会,一旦突破压力形成反转,则可以继续持有或增仓。底部横盘短线买入的错误机会只有一次,那就是你买在最高价,其他任何价位买入都是正确的,所以,利用KDJ选择买入机会,一定要结合趋势行情的情况来判定,也就是根据趋势的压力和支撑信号来判断顶部或底部的横盘走势,不可以机械地应用。